[OA-Tsc] update of the cmake minimum version for openamp and libmetal libraries

Arnaud POULIQUEN arnaud.pouliquen at st.com
Wed Jul 8 07:11:02 UTC 2020


Dear TSC members,

Ed and I are having a discussion about the minimal version of cmake that we should support for the openamp and libmetal libraries.
Today, the minimum supported version (checked during cmake runtime) is cmake v2.6.
This constraint on the minimum supported version was specified when the libraries were created and has never been updated.

In our environment we test the libraries with cmake V3.x, so cmake v2.6 support is no longer guaranteed.

Our proposal is to update the minimum version to 3.5 which corresponds to a version that we can simply test as part of the Ubuntu Xenial (16.04 LTS) distribution.
This could be effective for next October release.

As this update may be part of the stability policy, we would like to be sure that there are no objections from members before proposing a pull request..
So, If you have any objections or concerns about this update, please let us know.

Thanks and Regards,

Arnaud



More information about the Tsc mailing list