Branch: refs/heads/main
Home: https://github.com/OpenAMP/open-amp
Commit: ca56246b19dcf2995dbf5bb75d0b0e596611e8de
https://github.com/OpenAMP/open-amp/commit/ca56246b19dcf2995dbf5bb75d0b0e59…
Author: Andrew Davis <afd(a)ti.com>
Date: 2024-04-23 (Tue, 23 Apr 2024)
Changed paths:
M cmake/options.cmake
M lib/include/openamp/virtio.h
M lib/remoteproc/remoteproc.c
M lib/remoteproc/remoteproc_virtio.c
M lib/rpmsg/rpmsg_virtio.c
M lib/virtio/virtio.c
M lib/virtio/virtqueue.c
Log Message:
-----------
lib: Use VIRTIO_{DRIVER,DEVICE}_SUPPORT to improve readability
Currently compiler defines are defined when support for driver or device
is the only support being built. This is a negative define, it surrounds
the code to not be built and we use ifndef. This is confusing. It also
leaves ifndefs all throughout the code-base. Instead, define a macro that
is set to 1 if support is enabled. Use this inline in if statements where
possible. Any sane compiler will optimize away the code in the branch
when support is not enabled just the same as when using the preprocessor
so we keep the same binary size.
Signed-off-by: Andrew Davis <afd(a)ti.com>
Commit: 7a8c29275460855a997eefbebfb2a2dbe100076b
https://github.com/OpenAMP/open-amp/commit/7a8c29275460855a997eefbebfb2a2db…
Author: Andrew Davis <afd(a)ti.com>
Date: 2024-04-23 (Tue, 23 Apr 2024)
Changed paths:
M lib/include/openamp/virtio.h
M lib/remoteproc/remoteproc.c
M lib/remoteproc/remoteproc_virtio.c
M lib/rpmsg/rpmsg_virtio.c
M lib/virtio/virtio.c
M lib/virtio/virtqueue.c
Log Message:
-----------
lib: Add and use VIRTIO_ENABLED() macro
Checks if this symbol is defined and set to equal 1. Used to make it
more clear that a preprocessor level check is intended.
Signed-off-by: Andrew Davis <afd(a)ti.com>
Commit: f939a8614392c6a4f216660169ac73f846f1516d
https://github.com/OpenAMP/open-amp/commit/f939a8614392c6a4f216660169ac73f8…
Author: Andrew Davis <afd(a)ti.com>
Date: 2024-04-23 (Tue, 23 Apr 2024)
Changed paths:
M lib/include/openamp/virtio.h
M lib/remoteproc/remoteproc_virtio.c
M lib/virtio/virtio.c
M lib/virtio/virtqueue.c
Log Message:
-----------
lib: Add and use VIRTIO_ROLE_IS_{DRIVER,DEVICE}() macros
There is a common pattern of checking the virtio role while also checking
that this role is supported in this build, which can help optimize away
unusable code. Add a couple macros for this. This has two main benefits,
first being shorter and easier to read if statements, and also makes it
easier to not forget to always do both checks.
Use these everywhere except rpmsg_virtio.c which needs one more refactor
before we can switch it over.
Signed-off-by: Andrew Davis <afd(a)ti.com>
Compare: https://github.com/OpenAMP/open-amp/compare/fd6a6fdda776...f939a8614392
To unsubscribe from these emails, change your notification settings at https://github.com/OpenAMP/open-amp/settings/notifications
Branch: refs/heads/main
Home: https://github.com/OpenAMP/open-amp
Commit: fd6a6fdda7760f565e12ed0e74cbd0d3a6089cb2
https://github.com/OpenAMP/open-amp/commit/fd6a6fdda7760f565e12ed0e74cbd0d3…
Author: Andrew Davis <afd(a)ti.com>
Date: 2024-04-23 (Tue, 23 Apr 2024)
Changed paths:
M apps/CMakeLists.txt
A apps/include/platform_info_common.h
M apps/machine/microblaze_generic/platform_info.h
M apps/machine/zynq7/platform_info.h
M apps/machine/zynqmp/platform_info.h
M apps/machine/zynqmp_r5/platform_info.h
M apps/system/linux/machine/generic/platform_info.h
Log Message:
-----------
apps: Move common function declaration to common header
Several platform_*() functions are common across the example machines.
They actually have to be as they are consumed by example apps that build
across these machines. Move these common declarations to common a header.
Signed-off-by: Andrew Davis <afd(a)ti.com>
To unsubscribe from these emails, change your notification settings at https://github.com/OpenAMP/open-amp/settings/notifications
Branch: refs/heads/main
Home: https://github.com/OpenAMP/open-amp
Commit: 793851621d9e4bc71c5175a7efeb09223e87600f
https://github.com/OpenAMP/open-amp/commit/793851621d9e4bc71c5175a7efeb0922…
Author: Arnaud Pouliquen <arnaud.pouliquen(a)foss.st.com>
Date: 2024-04-19 (Fri, 19 Apr 2024)
Changed paths:
M lib/include/openamp/rpmsg_virtio.h
M lib/rpmsg/rpmsg_virtio.c
Log Message:
-----------
rpmsg_virtio: fix initialized notify_wait_cb
The rvdev->notify_wait_cb is not initialized to NULL if
not set by the user.
Initialize it to NULL and provide an API for the application to set it.
Signed-off-by: Arnaud Pouliquen <arnaud.pouliquen(a)foss.st.com>
To unsubscribe from these emails, change your notification settings at https://github.com/OpenAMP/open-amp/settings/notifications
Branch: refs/heads/main
Home: https://github.com/OpenAMP/open-amp
Commit: 3eab0819e51e46d05563bce3bc6a1e94d4b26ee8
https://github.com/OpenAMP/open-amp/commit/3eab0819e51e46d05563bce3bc6a1e94…
Author: Andrew Davis <afd(a)ti.com>
Date: 2024-04-17 (Wed, 17 Apr 2024)
Changed paths:
M lib/virtio_mmio/virtio_mmio_drv.c
Log Message:
-----------
virtio-mmio: Use the vmdev IO region for vq_ring.desc
The metal_io_region in the virtqueue struct is for translating
the buffer address stored in the virtqueue descriptor table, not
the address of the descriptor table itself.
This may have worked previously if the vring descriptors where part
of the same IO space as the buffers they point to, but this is not
guaranteed to always be the case. Fix that here.
Signed-off-by: Andrew Davis <afd(a)ti.com>
Commit: 4db4a08135ab295bd51e09ff44e20bf164d2001d
https://github.com/OpenAMP/open-amp/commit/4db4a08135ab295bd51e09ff44e20bf1…
Author: Andrew Davis <afd(a)ti.com>
Date: 2024-04-17 (Wed, 17 Apr 2024)
Changed paths:
M lib/include/openamp/virtqueue.h
Log Message:
-----------
virtqueue: Fix comment on shm_io and fix type
This should hold a pointer to a metal_io_region, make that the type.
Also fix the comment above this variable. This region holds the address
of the message buffers, not the vring descriptor table nor available/used
ring data. It is only used for virt-to-phys/phys-to-vert translation on
the buffers pointed to by these descriptors.
Signed-off-by: Andrew Davis <afd(a)ti.com>
Compare: https://github.com/OpenAMP/open-amp/compare/20ba140e7288...4db4a08135ab
To unsubscribe from these emails, change your notification settings at https://github.com/OpenAMP/open-amp/settings/notifications
Branch: refs/heads/main
Home: https://github.com/OpenAMP/libmetal
Commit: 959fddbd706a67b0699e0dd7a46e36fe49079ef9
https://github.com/OpenAMP/libmetal/commit/959fddbd706a67b0699e0dd7a46e36fe…
Author: Andrew Davis <afd(a)ti.com>
Date: 2024-04-11 (Thu, 11 Apr 2024)
Changed paths:
M README.md
M cmake/syscheck.cmake
Log Message:
-----------
Update build for latest Zephyr
The toolchain selection env var has been renamed
ZEPHYR_TOOLCHAIN_VARIANT, update the README.
Including boilerplate.cmake directly is deprecated, use
find_package(Zephyr).
Signed-off-by: Andrew Davis <afd(a)ti.com>
To unsubscribe from these emails, change your notification settings at https://github.com/OpenAMP/libmetal/settings/notifications
Branch: refs/heads/virtio-exp
Home: https://github.com/OpenAMP/open-amp
Commit: 7cad4e88e2717f8b84c1fe8c9496a6748d4e49b5
https://github.com/OpenAMP/open-amp/commit/7cad4e88e2717f8b84c1fe8c9496a674…
Author: Dan Milea <dan.milea(a)windriver.com>
Date: 2024-04-11 (Thu, 11 Apr 2024)
Changed paths:
M cmake/options.cmake
M lib/include/openamp/virtio_mmio.h
A lib/include/openamp/virtio_mmio_hvl.h
M lib/virtio/virtqueue.c
M lib/virtio_mmio/CMakeLists.txt
M lib/virtio_mmio/virtio_mmio_drv.c
A lib/virtio_mmio/virtio_mmio_hvl.c
M lib/virtio_mmio/virtio_serial_drv.c
Log Message:
-----------
virtio-mmio: hypervisor-less mode
Added support for hypervisor-less virtio.
- HVP dispatch function table
- Semaphore-based configuration synchronization mechanism when in
yield-capable context
Signed-off-by: Dan Milea <dan.milea(a)windriver.com>
To unsubscribe from these emails, change your notification settings at https://github.com/OpenAMP/open-amp/settings/notifications
Dear OpenAMP users,
Exceptionally, due to constraints from the OpenAMP maintainers, the delivery originally
Scheduled for the end of April has been postponed to the end of May.
We thank you in advance for your understanding and hope that this postponement will not
impact your projects.
Regards,
Arnaud
ST Restricted
Branch: refs/heads/main
Home: https://github.com/OpenAMP/open-amp
Commit: 1680aada793d78b512f98cc1fa8fc2ee837919e5
https://github.com/OpenAMP/open-amp/commit/1680aada793d78b512f98cc1fa8fc2ee…
Author: Andrew Davis <afd(a)ti.com>
Date: 2024-04-09 (Tue, 09 Apr 2024)
Changed paths:
M lib/include/openamp/remoteproc.h
M lib/remoteproc/remoteproc.c
Log Message:
-----------
remoteproc: Un-inline remoteproc_init_mem() and remoteproc_add_mem()
Having these functions as inline header functions forces the contents of
struct remoteproc_mem to remain externally exposed. It also does not save
space in most cases as every call-site gets the full contents of the
function instead of just a call instruction. Make these normal functions
like all others in remoteproc.h.
Signed-off-by: Andrew Davis <afd(a)ti.com>
To unsubscribe from these emails, change your notification settings at https://github.com/OpenAMP/open-amp/settings/notifications