Previously fields for packet struct definition were bare 'unsigned'. Change to unsigned int for clarity.
Signed-off-by: Ben Levinsky ben.levinsky@xilinx.com --- apps/examples/oob_echo/rpmsg-echo.h | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/apps/examples/oob_echo/rpmsg-echo.h b/apps/examples/oob_echo/rpmsg-echo.h index 24febd9..b5a3199 100644 --- a/apps/examples/oob_echo/rpmsg-echo.h +++ b/apps/examples/oob_echo/rpmsg-echo.h @@ -12,9 +12,9 @@ #define BUFFER_SIZE 0x10000UL //64K.. can change to 65K as needed
static struct packet { - unsigned packet_type; - unsigned buffer_index; - unsigned packet_length; + unsigned int packet_type; + unsigned int buffer_index; + unsigned int packet_length; };
#define LPRINTF(format, ...) printf(format, ##__VA_ARGS__)